Forum > Hardware > Problem z routerem (ap client)

Strona 1 z 1 1
skocz

djluke

  • djluke
  • wiadomość Użytkownik
  • Znawca sprzętu komputerowegoMiły gość

  • 36590 wypowiedzi

Wysłane 2020-01-17 22:26 , Edytowane 2020-01-19 23:53

Środowisko:
- główny router Huawei B525s
- Tp-link 702N 802N v2 jako klient
- do niego podpięta drukarka po kablu.

Problem:
Tplink (a z nim drukarka) nie widzi internetu.

Co robię źle? Jak to zrobić/obejść?

Oczywiście Tplink jako client, jest w sieci Huaweia, DHCP off a drukarki nie widać, niezależnie czy jej ustawię auto czy wpiszę  ręcznie w podsieci.

Asus TUF Gaming X570 Plus, Ryzen 3700X, BeQuiet Dark Rock 4 Pro, 16GB Patriot Viper 4 3733MHz CL17, Gigabyte RX 5700 XT Gaming OC 8GB, SSD Gigabyte Aorus 1TB, WD WD80EZAZ, Seasonic Focus Plus Gold 650W, Fractal Design Define R6 USB-C, Razer BlackWidow Ultimate, Logitech MX Master i reszta złomu; Windows 10; Samsung C27F591; HP Color Laserjet Pro M281fdn.

qra633

Wysłane 2020-01-18 01:46

Kiedyś robiłem takie konfiguracje na tomato. Ustawienie WiFi jako klient powodowało że sprzęt nadal działał jako router, czyli wifi przejmowało zadanie WANu a reszta była w swoim LANie czyli za kolejnym Natem.
Dopiero przełączenie wifi w tryb bridge powodowało że drugi router stawał się "przeźroczysty" i urządzenia do niego podłączone (w twoim przypadku drukarka do Tp-linka) zachowywały się jak podłaczone bezpośrednio do pierwszego routera, więc można było ustawić dostęp od strony internetu.

Frost

  • Frost
  • wiadomość Użytkownik

  • 2581 wypowiedzi

Wysłane 2020-01-18 20:50

Ten tryb nazywa się WISP. Jeżeli faktycznie tak masz to ustawione to ja kolega gada musisz go ustawić transparentnie w jakimś trybie AP bridge lub pochodnym. Nie wiem czy defaultowo TPlink będzie to miał. Możliwe, że będziesz musiał wgrać coś typu Gargoyle lub pochodna tego. Będziesz wtedy miał wszystko na jednym Lanie i przy tych ustawieniach które już masz ustawione (DHCP i adres na lanie po stronie klienta) wszystko będzie hulało. Natomiast kabel zawsze pewniejszy. Nie ufam tym bezprzewodowym mostom na domowych urządzeniach. Dopiero UBNT czy MT to półka w której wiesz, że będzie to śmigać.

Maveriq

Wysłane 2020-01-19 06:18 , Edytowane 2020-01-19 06:19

Kiedyś jakiegoś TP-Linka ustawiałem w takiej konfiguracji jako AP Client i hulało.
W ustawieniach na drukarce próbowałeś wstawic stałe IP?

To pewnie glupie pytanie znając autora posta, ale nie wpiąłeś mu czasem tej drukarki pod USB? :)

Ryzen R5 1500X; SPC Fortis 3; GA-AB350-Gaming 3; 32GB Corsair Vengeance 2400MHz CL14; Gigabyte RX560 OC; 128GB Samsung 830 + 1TB WD Blue; Logitech X-530 + Tonsil Fenix II Front + wzm. Technics; Corsair CMPSU-520HXEU - 520W; LCD Iiyama XB2483HSU; Microsoft Natural Ergo 4000; Gigabyte M8000x; HP DeskJet 5740.

emitar

  • emitar
  • wiadomość Użytkownik

  • 4868 wypowiedzi

Wysłane 2020-01-19 08:06 , Edytowane 2020-01-19 08:06

Jakby było tam openwrt to
service dnsmasq stop
ostatnio w gui też miałem dhcp wyłączone, a jednak dalej chodziło w tle i robiło problemy.

Y700 (i5-6300HQ 2.3 GHz, 8GB, M6GV 128GB + 1TB, GTX960M)

Mr. Nrvs

Wysłane 2020-01-19 10:27

Wyłącz DHCP na Tp linku i ustaw mu ip inne niz na routerze oraz ustaw tą samą maskę i powinno śmigać.

djluke

  • djluke
  • wiadomość Użytkownik
  • Znawca sprzętu komputerowegoMiły gość

  • 36590 wypowiedzi

Wysłane 2020-01-19 18:20 , Edytowane 2020-01-23 12:50

@Mr. Nrvs
Wiem że powinno ale nie śmiga.

@emitar
Żeby było tam *WRT to by trza było przelutować RAM i ROM na większe (procedura wgrania przewiduje takie kroki).

@Maveriq
Nie \"\lol\" pod USB idzie zasilanie. Nie mam nawet kabla RJ-USB.
Stałe czy zmienne IP, wyszukiwanie przez komputer, router, aplikację HP, Fing...faktycznie jakby dodatkowy NAT był.

@Frost
Próbowałem właśnie (czytałem o różnych bugach/konfliktach trybu client na innych TP-Linkach), być może nie tak ustawiałem. Wiem że wyrzucało mi błąd że TPlink nie może być w tej samej podsieci co router główny (?) czy coś takiego.

Generalnie jakby ktoś nie był w temacie to rozmawiamy o czymś takim [LINK] a tutaj emulator tego cuda [LINK]

Zaktualizowałem linki do poprawnego routera.

Asus TUF Gaming X570 Plus, Ryzen 3700X, BeQuiet Dark Rock 4 Pro, 16GB Patriot Viper 4 3733MHz CL17, Gigabyte RX 5700 XT Gaming OC 8GB, SSD Gigabyte Aorus 1TB, WD WD80EZAZ, Seasonic Focus Plus Gold 650W, Fractal Design Define R6 USB-C, Razer BlackWidow Ultimate, Logitech MX Master i reszta złomu; Windows 10; Samsung C27F591; HP Color Laserjet Pro M281fdn.

emitar

  • emitar
  • wiadomość Użytkownik

  • 4868 wypowiedzi

Wysłane 2020-01-19 22:41

Może to kwestia DNSów?

Y700 (i5-6300HQ 2.3 GHz, 8GB, M6GV 128GB + 1TB, GTX960M)

djluke

  • djluke
  • wiadomość Użytkownik
  • Znawca sprzętu komputerowegoMiły gość

  • 36590 wypowiedzi

Wysłane 2020-01-19 23:57

Byłem się tym dziś pobawić.

Po pierwsze to jednak 802N, nie 702N. O ile to jakakolwiek różnica.
Ale konkluzja na chwilę obecną jest taka że...po resecie do fabrycznych nie mogę do niego wejść i nie przyznaje IP. Albo się nie resetuje albo nie wiem...soft poleciał? Ale od czego? Wziąłem go i się na dniach pobawię.

Asus TUF Gaming X570 Plus, Ryzen 3700X, BeQuiet Dark Rock 4 Pro, 16GB Patriot Viper 4 3733MHz CL17, Gigabyte RX 5700 XT Gaming OC 8GB, SSD Gigabyte Aorus 1TB, WD WD80EZAZ, Seasonic Focus Plus Gold 650W, Fractal Design Define R6 USB-C, Razer BlackWidow Ultimate, Logitech MX Master i reszta złomu; Windows 10; Samsung C27F591; HP Color Laserjet Pro M281fdn.

Maveriq

Wysłane 2020-01-20 04:28 , Edytowane 2020-01-20 04:34

A po resecie nadaje komputerowi prawidłowy IP, czy z kosmosu?
Używałem tego do podpinania w sieć dekoderów z Multiroom i zawsze odbywało się bez problemów i bez wielkiego kombinowania. Włączony tryb klient, wyłączenie DHCP, wyłączenie NAT, połączenie przez WiFi z routerem i to wszystko.

Ryzen R5 1500X; SPC Fortis 3; GA-AB350-Gaming 3; 32GB Corsair Vengeance 2400MHz CL14; Gigabyte RX560 OC; 128GB Samsung 830 + 1TB WD Blue; Logitech X-530 + Tonsil Fenix II Front + wzm. Technics; Corsair CMPSU-520HXEU - 520W; LCD Iiyama XB2483HSU; Microsoft Natural Ergo 4000; Gigabyte M8000x; HP DeskJet 5740.

qra633

Wysłane 2020-01-21 23:25

sprawdziłem jak wygląda menu na symulatorach z linku.
W 702N jest opcja Bridge w zakładce Wireless Working. W 802n już tej funkcji nie ma. :(

djluke

  • djluke
  • wiadomość Użytkownik
  • Znawca sprzętu komputerowegoMiły gość

  • 36590 wypowiedzi

Wysłane 2020-01-23 13:12 , Edytowane 2020-01-23 14:38

No nie ma, ale jest WISP (Wireless Hotspot czy jakoś tak - druga opcja). Spróbuję z tym - bo jak to nie zadziała to nic nie zadziała, nie?

Zaktualizowałem linki jak coś, bo z początku pomyliłem routery...

Jeszcze jedno: w trybie WISP adres LAN i WAN nie mogą być w tej samej podsieci...zadziała? Wyszuka mi drukarkę o adresie w innej podsieci? DHCP w ogóle przejdzie?

Asus TUF Gaming X570 Plus, Ryzen 3700X, BeQuiet Dark Rock 4 Pro, 16GB Patriot Viper 4 3733MHz CL17, Gigabyte RX 5700 XT Gaming OC 8GB, SSD Gigabyte Aorus 1TB, WD WD80EZAZ, Seasonic Focus Plus Gold 650W, Fractal Design Define R6 USB-C, Razer BlackWidow Ultimate, Logitech MX Master i reszta złomu; Windows 10; Samsung C27F591; HP Color Laserjet Pro M281fdn.

Frost

  • Frost
  • wiadomość Użytkownik

  • 2581 wypowiedzi

Wysłane 2020-01-23 15:58

WISP to przesunięcie WANa na AP. Odbierasz bezprzewodowo a po kablu masz swój LAN. Twoim WANem jest połączenie bezprzewodowwe a nie niebieski port w TPlinkach.
Zasadą działania routera jest łączenie dwóch sieci (2 różne adresacje). DHCP będzie Ci śmigało po stronie LANa ale niczego to nie zmieni. W tym trybie nie będzie to śmigało. No chyba, że masz tam gdzieś opcję Bridge'a lub coś ala transparent mode, wtedy router jest "przeźroczysty".

djluke

  • djluke
  • wiadomość Użytkownik
  • Znawca sprzętu komputerowegoMiły gość

  • 36590 wypowiedzi

Wysłane 2020-01-23 19:50 , Edytowane 2020-01-23 20:06

@Frost
Mam to co tutaj [LINK]

A jakby tak Client i dodać regułkę w Advanced routing?

Asus TUF Gaming X570 Plus, Ryzen 3700X, BeQuiet Dark Rock 4 Pro, 16GB Patriot Viper 4 3733MHz CL17, Gigabyte RX 5700 XT Gaming OC 8GB, SSD Gigabyte Aorus 1TB, WD WD80EZAZ, Seasonic Focus Plus Gold 650W, Fractal Design Define R6 USB-C, Razer BlackWidow Ultimate, Logitech MX Master i reszta złomu; Windows 10; Samsung C27F591; HP Color Laserjet Pro M281fdn.

djluke

  • djluke
  • wiadomość Użytkownik
  • Znawca sprzętu komputerowegoMiły gość

  • 36590 wypowiedzi

Wysłane 2020-01-24 00:19 , Edytowane 2020-01-24 00:19

Udało się !!! \"\jupi\"

Po tygodniach prób, konfiguracji, przenoszenia ruterów itp. okazało się, że winny był...wygięty pin w porcie RJ drukarki jego mać! \"\zly\"\"\zly\"\"\zly\"

Jakby nie to to działałoby od początku i w ogóle nie byłoby tego tematu \"\obcy\"

Asus TUF Gaming X570 Plus, Ryzen 3700X, BeQuiet Dark Rock 4 Pro, 16GB Patriot Viper 4 3733MHz CL17, Gigabyte RX 5700 XT Gaming OC 8GB, SSD Gigabyte Aorus 1TB, WD WD80EZAZ, Seasonic Focus Plus Gold 650W, Fractal Design Define R6 USB-C, Razer BlackWidow Ultimate, Logitech MX Master i reszta złomu; Windows 10; Samsung C27F591; HP Color Laserjet Pro M281fdn.

Maveriq

Wysłane 2020-01-24 00:42

To wrzuć screena ustawień dla potomnych, bo za rok znowu ktoś będzie podpowiadał, że bridge mode jest do tego potrzebny.

Ryzen R5 1500X; SPC Fortis 3; GA-AB350-Gaming 3; 32GB Corsair Vengeance 2400MHz CL14; Gigabyte RX560 OC; 128GB Samsung 830 + 1TB WD Blue; Logitech X-530 + Tonsil Fenix II Front + wzm. Technics; Corsair CMPSU-520HXEU - 520W; LCD Iiyama XB2483HSU; Microsoft Natural Ergo 4000; Gigabyte M8000x; HP DeskJet 5740.

djluke

  • djluke
  • wiadomość Użytkownik
  • Znawca sprzętu komputerowegoMiły gość

  • 36590 wypowiedzi

Wysłane 2020-01-24 11:09

OK, instrukcja jak ustawić router TP-Link WR802N (i pewnie podobne) do pracy jako klient WiFi dla urządzeń wyposażonych jedynie w port LAN. Najprościej skorzystać z kreatora i taką drogę opiszę, ale pojedyncze kroki można wykonać samemu niezależnie od innych. Najbezpieczniej robić to podłączonym pod LAN.

1. Jako tryb pracy (Operation mode) wybieramy Client. Router prawdopodobnie się zrestartuje.
2. Z listy znalezionych sieci wybieramy tą, z którą chcemy się połączyć.
3. W kolejnym kroku podajemy hasło do ww. sieci.
4. Dalej zostawiamy jak jest - tryb Smart DHCP - trochę mylna nazwa, router "przepuszcza" polecenia DHCP z głównego rutera, sam staje się przezroczysty..
5. Weryfikujemy ustawienia i kończymy setup.
6. Jeśli to nie było nasze urządzenie docelowe do podłączenia - podłączamy je do portu LAN routera. Gdy dioda zapali się stałym zielonym światłem - mamy połączenie, zaś urządzenie docelowe powinno dostać adres IP z routera głównego. Podsieć, w jakiej był wcześniej TP-Link, nie ma znaczenia. Dostanie on też IP w podsieci routera głównego.

Asus TUF Gaming X570 Plus, Ryzen 3700X, BeQuiet Dark Rock 4 Pro, 16GB Patriot Viper 4 3733MHz CL17, Gigabyte RX 5700 XT Gaming OC 8GB, SSD Gigabyte Aorus 1TB, WD WD80EZAZ, Seasonic Focus Plus Gold 650W, Fractal Design Define R6 USB-C, Razer BlackWidow Ultimate, Logitech MX Master i reszta złomu; Windows 10; Samsung C27F591; HP Color Laserjet Pro M281fdn.
Strona 1 z 1 1
skocz

Kto jest online: 1 użytkowników, 74 gości

Cursed ,